AT89LP4052 programming not working

Started by mik3ca 5 years ago1 replylatest reply 5 years ago136 views

For the life of me, I can't figure out why I can't program the AT89LP4052.

I have programmed the AT89S52 and AT89LP52 before serially with my own hardware board.

Now I made a hardware board for the AT89LP4052 with the exact same connections to my computer except I tied P1.4 (the new CS/SS line) to the reset pin because the datasheet instructions tell me those pins must be high when programming the AT89LP4052. I also used the same software I made (to program the AT89S52 and AT89LP52) to try to program the AT89LP4052.

After reading Microchips datasheets, I noticed they incorrectly stated that one must send AAh and 55h before any command to interact with the AT89LP5x series of chips. I never had to do that when I programmed them serially and I got them to work.

Now the AT89LP4052 is a strange beast because when I try my programmer and even tried adjusting parameters, all I get back are all zero bits. I even replaced the micro with another and still get the same results.

Anyways, these are the bytes I have sent to the AT89LP4052 in attempts to get its signature which clearly is not 0h 0h 0h:

AAh ACh 53h (to enable Serial programming)

AAh 28h 0h 0h (to get signature)

then I read the next 8 bits only to get a value of 0.

I'm going to see if Atmel/Microchip once again has messed up their documents and I'll see if I can get a signature a different way through serial.

If anyone has a solution to this, I'd be happy to hear it.

[ - ]
Reply by mr_banditJanuary 22, 2019

Have you contacted microchip tech support?

Have you looked at the errata?